Tuesday, 20 March 2012

Getting the Arnova 9 G2 into Recovery Mode

To enter Arnova 9 G2 recovery mode, press the esc button then using a paperclip press the recessed reset button (its located on the top edge of the Arnova). It will now enter the recovery mode. A rooted verion of the Arnova9G2 firmware is available here. Plug in the micro USB to your computer I have Windows 7 installed. After a time it should show in the Windows 7 Device Manager with a RK29? Device, ignore the ? Now right click on the RK29? entry and select update driver. Then choose the browse option and navigate to the folder where you unzipped the file you downloaded previously, usually the Downloads folder, "arnova G2_full_root_rom_V1.0_arctools\drivers\32bit\win7" that contains the driver for your flavour of Windows 7, mine was the 32 bit driver. Once Windows has indicated that the driver install was successful you can now run the firmware update tool RK29update.exe located in the root of the arnova G2_full_root_rom_V1.0_arctools folder.
Update
I found that after the update I couldn't enter recovery mode it appears to be as described on Recovery Mode

Friday, 9 March 2012

OpenWRT MR3220 Command Snippets

Reset the OpenWRT on Router back to the default use the command mtd -r erase rootfs_data

Turn Wifi off uci set wireless.@wifi-device[0].disabled=1; wifi

Thursday, 8 March 2012

Using a clone image on new hardware.

The Centos networking will not work after the new hardware is using a clone image. The problem occurs because the MAC addresses on the new hardware don't match the MAC addresses in the config files of the clone image, these are the MAC addresses of the original hardware the image was taken from.

To get Networking working on Centos when using a cloned image, just modify the entries in /etc/sysconfig/network-scripts/ifcfg-eth0 ifcfg-eth1 and the /etc/udev/rules.d/70-persistent-net.rules files so that the eth0 and eth1 entries match the new hardware MAC addresses.

Restart the networking using service network restart and networking should now be working.